Home Forums Prusa i3 Repairing a bad PINDA Cable

This topic contains 12 replies, has 4 voices, and was last updated by  gwlinn 6 months, 3 weeks ago.

Viewing 13 posts - 1 through 13 (of 13 total)
  • Author
  • #4641


    My MK2 had been working perfectly for some time. Then, the extruder halted as I began a new print and I got a message saying something like “Z axis wiring open or shorted”. When I tried to AutoHome, the nozzle was crashing into the bed from the first step so something was definitely wrong.

    I noticed that the PINDA probe was “loose” in its mounting. It was not out of the mount, but the lock nut was loose. Still, I didn’t see how it could have rotated enough to cause the problem because of the way the cable is constrained by the extruder housing. I did learn from the initial assembly that the probe needs to be pretty close to the bed surface or the nozzle will crash. So, I tried to adjust closer, without any improvement.

    I looked at the “Show End Stops” menu. X and Y were “0” but Z was “1”. Next, I removed and reconnected the PINDA connector in the Rambo. No change in the Z end stop reading. So, I wiggled the cable between the extruder and the Rambo and COULD cause Z to toggle between “0” and “1”. So, there was a fault in the PINDA cable.

    Of course, if you don’t see a toggle, the problem could still be in the cable or the Rambo. If I would have had a spare Rambo “Z Axis End Stop” connector, I could have simulated the PINDA to isolate further since the PINDA appears to simply output a “0” or “1” depending upon its proximity to metal. But, I didn’t and I didn’t want to probe and accidently zap the Rambo.

    I couldn’t locate the exact fault location in the cable. The 3 wire PINDA cable is “trapped” in the extruder housing so it’s not possible, as far as I can tell, to remove the cable without taking the extruder completely apart. I didn’t want to do this but needed access to BOTH ends of the cable. I stripped the vinyl jacket off the cable starting at the Rambo connector end. Luckily, there isn’t any shielding so this was pretty easy. Then, I cut the cable completely about an inch or so from the PINDA.

    I did a continuity test on the three wires from the Rambo connector end to where I had cut the cable at the sensor. Be sure to use a small pin at the Rambo end so you don’t damage the connector and cause a loose connection there. I found that the black wire was open. Most likely, the wiring had been “stressed” during factory cable assembly and broke after repeated flexing. I replaced the black wire with a #26 stranded wire, soldered and shrink-wrapped all the joints, and reassembled the extruder-to-Rambo bundle. In hindsight, maybe I should have replaced all three wires as there is probably another similar repair in my future.

    Since I had removed the PINDA from its mount to work on it, I readjusted its height the best I could guess. “Show End Stops” showed all axes “0” as expected. I ran AutoHome. The first 3 points across the front “passed”, but the 4th point, at the right side, middle, crashed. Now what? I readjusted the probe CLOSER to the bed. Now, all works okay. Ran all calibrations okay and printed a part.



    Hi gwlinn I´ve a similar problem, sometimes (not always 1 out of 3 more or less) in the begining of a printing when my MK2 do the routine “calibration Z”, in the last point (upper right) the extruder touch and push the bed down 5mm at least, after that, it start printing or if I run “calibration Z” only the LCD display show “MK2 ready”, the level of the z axis gets poorly aligned and I can´t print in the upper right corner, what do you think the problem could be? the printer structure is well build, I checked it on and on again



    The machine is new, this thing started from the begining



    I can understand your frustration. First of all, if the machine is new, Prusa should be more willing to help. The first thing I would check is that you have the latest software installed. After building, I had to update mine before the printer would calibrate correctly.

    Assuming that you looked at the “Show End Stops” menu and were getting the correct values as I noted, then the PINDA is “good” (or maybe could still be intermittent). As I noted, even after I repaired it, I had to readjust it lower, closer to the bed, to get the 4th point, at the right side, middle, to not crash. Why? I don’t know.

    You can test the PINDA by raising Z and holding a piece of metal against it.

    Also, for whatever reason, your bed/machine may be more “out of level/square” than the calibration software can handle. (Like, maybe you got a “warped” bed.)

    Maybe the two Z axis stepper motors are not driving equally on both sides. I assume you have done the calibration by driving them to the top. But, assuming you have done this, maybe one of the steppers or the electronics or intermittent wiring is causing them to not always step the same amount. At least there isn’t any belt to slip in this axis. You might be able to test this theory after a crash by manually (using the manual z mode, NOT by hand) driving z almost to the top and looking to see if you can tell any difference between the left and right side. This may be hard to do since a small error may not be easily visually detectable.

    I know you are disappointed, but I would like to add that after I got going, the MK2 printed as well as and possibly better than my $2500 TAZ 5. Good Luck!

    The MK2 has now been out long enough that Prusa SHOULD have a fairly detailed troubleshooting diagram for you. Else they would have to spend too much time helping too many people getting up and running.



    Hi gwlinn!!! thanks for you quick response.

    I tell you that I dont update the software because I dont want to change anything until the printer is working properly. On the other hand the printer works from time to time, in fact is printing right now after 3 tries, the “show end stops” function marks all 0, about the frame of the bed is in square and to 10 cm the z axis from the rear plastics as the manual says, (I am a carpenter / Cabinetmaker so I know how to measure). Unfortunately the bed is warped, both right and left sides have a difference of 1 mm lower than the center, I put a square crossed to the Y axis and notice the difference, I had already noticed that before and wanted to supplement with washers but the screw is very short and no longer grab the bed, I did not think that could be a problem due to the leveling software that comes with the printer but from what you tell me it seems to affect, the stepper motors are good, so what I’m going to do, is get a few longer screws and try to straighten the bed.

    On the other hand, Prusa answered all my emails although they have not yet considered that something on the machine can be wrong, they just tell me to measure everything again.

    Thank you, I hope to solve it by straightening the bed.



    Okay. I have a couple of more thoughts.

    Software: Since your machine is newer than mine, perhaps yours came with a version newer than mine. My machine would not run at all with original software.

    Another way to check for bed warping would be to manually run the extruder over the bed and use shims to measure the offset. I used these when setting the points on my older, pre-electronic ignition, cars. Then, you could send a “map” of your bed to Prusa and ask if this amount of error can be corrected by their s/w calibration. It doesn’t matter what the message “says”, it matters what the s/w can actually do.

    Another possibility is that there is “binding”, maybe only intermittently, in one of the stepper axis. It is not impossible to “stop” a stepper and cause it to miss one or more steps and therefore both sides of the z axis would not be the same.
    1. Maybe there was a machining error in the vertical metal frame, like holes not drilled correctly for mounting the z axis parts.
    2. Maybe one the z axis bearings is binding.
    3. Maybe one of the z axis printed parts is defective, as in “split”.
    4. Check to see if one of the long z axis rods is warped.

    Since you are a carpenter, I would not expect that you “ham-handed” something during assembly.

    Carefully “reseat” the two z axis connectors on the electronics board. A “high resistance” connection might not allow sufficient current to flow to a stepper and then it could miss a step.

    Consider the power input to the machine. Like done for my computer, I have a battery backup on my printers. We get lots of power glitches here in Florida and I don’t want to have to restart a 25 hour run! Low or glitching power may not seem to be affecting anything but maybe it does in a subtle way in the stepper electronics. If you have the Prusa in your cabinetry shop, take note of whether you’re having problems while running a big saw or dust collection system. I am a hobbyist woodworker but mostly I make sawdust.

    Painful as it seems, I would take the entire z axis assembly apart and rebuild it while checking for defective parts and binding the best you can.

    I would be reluctant to try and flatten a warp bed until exhausting all other ideas.

    You might also want to collect more data like:
    1. Select a small object from the SD card
    2. Reprint it 10 times noting results
    3. Move the object to different places on the bed and repeat.
    4. Send the data to Prusa. Maybe they will send a new bed.

    One can see a disadvantage when ordering something from overseas. The cost to return anything could be enormous.

    Good luck, Gary



    When I said “shims” in my recent reply, I meant “feeler gauges”. It’s been so long since I needed them, I forgot the correct name! Gary



    I had a similar problem. I took the PINDA out, tested it on a breadboard which confirmed it works, and then reinstalled it. Once it was reinstalled, everything started working again. I have a bad feeling that the problem will be back, but for now, I’m just taking the win.



    Thanks for your post. Every experience helps someone. From my experience, intermittents don’t go away forever. But, at some point, you just have to give up testing and wait for the next fail. I think I mentioned that I wish I had replaced the entire cable. Surprisingly, the cable failed before the device. But, once you look inside how the cable is built, maybe it’s no surprise. At least you may now know how to test without pulling everything apart. I don’t blame Prusa as he is just trying to provide the best, cheapest, product. But, unless NASA built it, one shouldn’t expect anything to last a lifetime.



    Hi, has being a long time, the thing is that I had the printer work and I´ve been printing since that xD, sorry.

    My bed frame was a litlle bit curve, 1mm both sides on the front compare to the center, I fix that and began to work properly but the most important thing that I do before every print is to heat the bed 60°C with the PINDA close to it so it warm too, That is the key so my MK2 does not touch point 9, after that no problem at all, This machine is the best, thank you qwlinn



    Hi Guys,
    I’m building my brand new mk2s.. It failed self-test and says: The Z endstop is not wired correctly. Check the wiring.
    I’ve swapped the z axis endstop with the y axis on the Rambo board and now the fault has moved to the y axis.
    So that means that the PINDA probe isn’t working.:-(
    I’ve tried a lump of metal (spanner) underneath it and it still thinks nothing is there!
    How do I test the probe?



    Hi, first of all congratulations, you have an excelent printer, 2nd the z axis end stop is the PINDA and the x axis end stop is a switch so I dont think its going to work if you swap between them, If I remember correctly when I assembled my MK2 the manual said to be careful whit the tightness of the zipties of the back of extruder cause might strengulate the wires and damage them, maybe there is the problem, get another end stop conect it in the PINDA slot and trigger it manualy in the AUTO HOME function on CALIBRATE menu with 1 finger in the new end stop and another finger in the X (reset) botton to prevent the extruder to crash into the bed, the AUTO HOME first goes all the way back in the X axis, then the bed goes all the way back untill the Y axis end stop trigger and then the z axis begin to goes down, at any height press the new end stop to see if the software get the change in the reading, for what I can understand if it get the signal and z-axis stop, you have to change the PINDA, if doesnt get it the problem is in the RAMBO board or software.

    I hope I have helped you, be patient is worth it 😉



    It’s been a while since I worked on this so my knowledge had faded. I had managed to find a schematic of the Rambo while I was troubleshooting, but since you saw the problem move to a different axis, the problem would seem to be most likely associated with the probe. Some notes if you think it is in the PINDA:

    1. The physical wires in the 3 wire PINDA cable are VERY small. There is a power, ground, and signal wire. If ether one is open (or perhaps one is shorted to another) it won’t work. Even though the wires are enclosed in a vinyl jacket, they can still be stressed and broken (based upon my experience). Knowing what I saw, you could have very well received a bad sensor/cable in the first place. There is nothing to say that the sensor/cable was ever tested before shipping. It’s even possible that the cable was “mis-wired” at the factory!

    2. Take a close up, magnified, look at the Rambo end connector to make sure the connector is not damaged and that the “crimp” connections between the connector and the PINDA cable is good. But, sometimes, a problem may not be visible.

    3. Since I couldn’t easily and quickly get a new PINDA to try, I noted in my previous discussion that I “cut” the cable near the sensor (to be repaired later). After doing this, I use my ohmmeter to verify continuity from the Rambo connector cable end to the severed end of each wire. That’s how I proved the problem was in the cable, in the ground wire, AND intermittent!

    4. It’s also possible that “flexing” of the cable at the PINDA end caused a wire failure during installation. Maybe or maybe not your fault.

    If one knew (or I could remember) the specific voltage being supplied to the PINDA, one could easily test the PINDA completely (and simply) outside of the printer.

    1. Jury-rig voltage and ground to the appropriate pins on the PINDA connector (do NOT connect to the Rambo). The idea is to ISOLATE the probe and cable completely from the Rambo. Additionally, if you try to jumper from the Rambo, you risk damaging the connector on the Rambo and/or shorting something on the Rambo. I don’t know the exact voltage for sure, but it is probably +5, or maybe +12 or even +3.3. It would be safer to know the exact interface circuit on the Rambo before you applied any voltage. While I don’t think this is the case, just applying a voltage to something without a “limiting” resistor could damage the sensor. For example, if you apply a voltage directly to an LED without a limiting resistor, you kill it.
    2. With the voltage applied, measure the voltage between the signal pin and the ground pin without the PINDA near metal.
    3. Move a piece of metal, like a wrench, against the PINDA and verify that the signal to ground voltage has changed.

    Good Luck, Gary

Viewing 13 posts - 1 through 13 (of 13 total)

The forum ‘Prusa i3’ is closed to new topics and replies.